What’s Vulnerable › Vulnerabilities
CVE-2016-9591
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-09 · updated 2026-06-17
- Weakness: CWE-416
Description
JasPer before version 2.0.12 is vulnerable to a use-after-free in the way it decodes certain JPEG 2000 image files resulting in a crash on the application using JasPer.
Affected products
- Debian Linux: 8.0
- jasper: before 2.0.12 — fixed in 2.0.12
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Eus: 7.3, 7.4
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: jasper 2.0.12. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94952
- https://access.redhat.com/errata/RHSA-2017:1208
- https://bugzilla.redhat.com/show_bug.cgi?id=1406405
- https://security.gentoo.org/glsa/201707-07
- https://www.debian.org/security/2017/dsa-3827
- http://www.securityfocus.com/bid/94952
- https://access.redhat.com/errata/RHSA-2017:1208
- https://bugzilla.redhat.com/show_bug.cgi?id=1406405
- https://security.gentoo.org/glsa/201707-07
- https://www.debian.org/security/2017/dsa-3827
Get alerted when CVE-2016-9591 or the next vulnerability affects your stack