What’s Vulnerable › Vulnerabilities
CVE-2016-9601
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-24 · updated 2026-06-17
- Weakness: CWE-190
Description
ghostscript before version 9.21 is vulnerable to a heap based buffer overflow that was found in the ghostscript jbig2_decode_gray_scale_image function which is used to decode halftone segments in a JBIG2 image. A document (PostScript or PDF) with an embedded, specially crafted, jbig2 image could trigger a segmentation fault in ghostscript.
Affected products
- Artifex Gpl Ghostscript: before 9.21 — fixed in 9.21
- Artifex Jbig2Dec: through 0.13
- Debian Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: Artifex Gpl Ghostscript 9.21. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=jbig2dec.git%3Ba=commit%3Bh=e698d5c11d27212aa1098bc5b1673a3378563092
- http://www.securityfocus.com/bid/97095
- https://bugs.ghostscript.com/show_bug.cgi?id=697457
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9601
- https://security.gentoo.org/glsa/201706-24
- https://www.debian.org/security/2017/dsa-3817
- http://git.ghostscript.com/?p=jbig2dec.git%3Ba=commit%3Bh=e698d5c11d27212aa1098bc5b1673a3378563092
- http://www.securityfocus.com/bid/97095
- https://bugs.ghostscript.com/show_bug.cgi?id=697457
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9601
- https://security.gentoo.org/glsa/201706-24
- https://www.debian.org/security/2017/dsa-3817
Get alerted when CVE-2016-9601 or the next vulnerability affects your stack