What’s Vulnerable › Vulnerabilities
CVE-2016-9602
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-26 · updated 2026-06-17
- Weakness: CWE-59
Description
Qemu before version 2.9 is vulnerable to an improper link following when built with the VirtFS. A privileged user inside guest could use this flaw to access host file system beyond the shared folder and potentially escalating their privileges on a host.
Affected products
- Debian Linux: 8.0
- QEMU: before 2.9 — fixed in 2.9
How to fix
Upgrade to a fixed version: QEMU 2.9. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/01/17/12
- http://www.securityfocus.com/bid/95461
- http://www.securitytracker.com/id/1037604
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9602
- https://lists.debian.org/debian-lts-announce/2018/09/msg00007.html
- https://lists.gnu.org/archive/html/qemu-devel/2017-01/msg06225.html
- https://lists.gnu.org/archive/html/qemu-devel/2017-02/msg04347.html
- https://security.gentoo.org/glsa/201704-01
- http://www.openwall.com/lists/oss-security/2017/01/17/12
- http://www.securityfocus.com/bid/95461
- http://www.securitytracker.com/id/1037604
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9602
Get alerted when CVE-2016-9602 or the next vulnerability affects your stack