What’s Vulnerable › Vulnerabilities
CVE-2016-9603
- Severity: critical (CVSS 9.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-122
Description
A heap buffer overflow flaw was found in QEMU's Cirrus CLGD 54xx VGA emulator's VNC display driver support before 2.9; the issue could occur when a VNC client attempted to update its display after a VGA operation is performed by a guest. A privileged user/process inside a guest could use this flaw to crash the QEMU process or, potentially, execute arbitrary code on the host with privileges of the QEMU process.
Affected products
- Citrix XenServer: 6.0.2, 6.2.0-sp1, 6.5-sp1, 7.0, 7.1
- Debian Linux: 7.0
- QEMU: before 2.9.0 — fixed in 2.9.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4
- RedHat Enterprise Linux Server Eus: 7.3, 7.4, 7.5
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- OpenStack: 5.0, 6.0, 7.0, 8, 9, 10
How to fix
Upgrade to a fixed version: QEMU 2.9.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/96893
- http://www.securitytracker.com/id/1038023
- https://access.redhat.com/errata/RHSA-2017:0980
- https://access.redhat.com/errata/RHSA-2017:0981
- https://access.redhat.com/errata/RHSA-2017:0982
- https://access.redhat.com/errata/RHSA-2017:0983
- https://access.redhat.com/errata/RHSA-2017:0984
- https://access.redhat.com/errata/RHSA-2017:0985
- https://access.redhat.com/errata/RHSA-2017:0987
- https://access.redhat.com/errata/RHSA-2017:0988
- https://access.redhat.com/errata/RHSA-2017:1205
- https://access.redhat.com/errata/RHSA-2017:1206
Get alerted when CVE-2016-9603 or the next vulnerability affects your stack