What’s Vulnerable › Vulnerabilities
CVE-2016-9645: Editing restriction bypass for git revert
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-10 · updated 2026-06-17
- Weakness: CWE-284
Description
The fix for ikiwiki for CVE-2016-10026 was incomplete resulting in editing restriction bypass for git revert when using git versions older than 2.8.0. This has been fixed in 3.20161229.
Affected products
- ikiwiki: before 2.8 — fixed in 2.8
How to fix
Upgrade to a fixed version: ikiwiki 2.8. Check the vendor advisory for mitigations.
References
- https://ikiwiki.info/security/#cve-2016-9645
- https://marc.info/?l=oss-security&m=148304341511854&w=2
- https://security-tracker.debian.org/tracker/CVE-2016-9645
- https://ikiwiki.info/security/#cve-2016-9645
- https://marc.info/?l=oss-security&m=148304341511854&w=2
- https://security-tracker.debian.org/tracker/CVE-2016-9645
Get alerted when CVE-2016-9645 or the next vulnerability affects your stack