What’s Vulnerable › Vulnerabilities
CVE-2016-9646: Commit metadata forgery via CGI::FormBuilder context-dependent APIs
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-13 · updated 2026-06-17
- Weakness: CWE-287
Description
ikiwiki before 3.20161229 incorrectly called the CGI::FormBuilder->field method (similar to the CGI->param API that led to Bugzilla's CVE-2014-1572), which can be abused to lead to commit metadata forgery.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- ikiwiki: before 3.20161229 — fixed in 3.20161229
How to fix
Upgrade to a fixed version: ikiwiki 3.20161229. Check the vendor advisory for mitigations.
References
- https://ikiwiki.info/security/#cve-2016-9646
- https://marc.info/?l=oss-security&m=148304341511854&w=2
- https://security-tracker.debian.org/tracker/CVE-2016-9646
- https://www.debian.org/security/2017/dsa-3760
- https://ikiwiki.info/security/#cve-2016-9646
- https://marc.info/?l=oss-security&m=148304341511854&w=2
- https://security-tracker.debian.org/tracker/CVE-2016-9646
- https://www.debian.org/security/2017/dsa-3760
Get alerted when CVE-2016-9646 or the next vulnerability affects your stack