What’s Vulnerable › Vulnerabilities
CVE-2016-9686
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-02-08 · updated 2026-06-17
- Weakness: CWE-20
Description
The Puppet Communications Protocol (PCP) Broker incorrectly validates message header sizes. An attacker could use this to crash the PCP Broker, preventing commands from being sent to agents. This is resolved in Puppet Enterprise 2016.4.3 and 2016.5.2.
Affected products
- Puppet Enterprise: from 2016.4.0 before 2016.4.3; 2016.5.1 — fixed in 2016.4.3
How to fix
Upgrade to a fixed version: Puppet Enterprise 2016.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-9686 or the next vulnerability affects your stack