What’s Vulnerable › Vulnerabilities
CVE-2016-9794
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-12-28 · updated 2026-06-17
- Weakness: CWE-362
Description
Race condition in the snd_pcm_period_elapsed function in sound/core/pcm_lib.c in the ALSA subsystem in the Linux kernel before 4.7 allows local users to cause a denial of service (use-after-free) or possibly have unspecified other impact via a crafted SNDRV_PCM_TRIGGER_START command.
Affected products
- Linux kernel: before 3.2.85; from 3.3 before 3.10.105; from 3.11 before 3.12.69; from 3.13 before 3.16.40; from 3.17 before 3.18.52; from 3.19 before 4.4.37 — fixed in 3.10.105, 3.12.69, 3.16.40, 3.18.52, 3.2.85, 4.4.37
How to fix
Upgrade to a fixed version: Linux kernel 3.10.105, 3.12.69, 3.16.40, 3.18.52. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=3aa02cb664c5fb1042958c8d1aa8c35055a2ebc4
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00057.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00062.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00072.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00075.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00081.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00088.html
- http://lists.opensuse.org/opensuse-security-announce/2016-12/msg00091.html
- http://rhn.redhat.com/errata/RHSA-2016-2574.html
- http://www.openwall.com/lists/oss-security/2016/12/03/2
- http://www.securityfocus.com/bid/94654
- https://bugzilla.redhat.com/show_bug.cgi?id=1401494
Get alerted when CVE-2016-9794 or the next vulnerability affects your stack