What’s Vulnerable › Vulnerabilities
CVE-2016-9845
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-12-29 · updated 2026-06-17
- Weakness: CWE-200
Description
QEMU (aka Quick Emulator) built with the Virtio GPU Device emulator support is vulnerable to an information leakage issue. It could occur while processing 'VIRTIO_GPU_CMD_GET_CAPSET_INFO' command. A guest user/process could use this flaw to leak contents of the host memory bytes.
Affected products
- QEMU: before 2.8.0; 2.8.0-rc0, 2.8.0-rc1, 2.8.0-rc2 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: QEMU 2.8.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/12/05/15
- http://www.openwall.com/lists/oss-security/2016/12/05/22
- http://www.securityfocus.com/bid/94763
- https://lists.nongnu.org/archive/html/qemu-devel/2016-11/msg00019.html
- https://security.gentoo.org/glsa/201701-49
- http://www.openwall.com/lists/oss-security/2016/12/05/15
- http://www.openwall.com/lists/oss-security/2016/12/05/22
- http://www.securityfocus.com/bid/94763
- https://lists.nongnu.org/archive/html/qemu-devel/2016-11/msg00019.html
- https://security.gentoo.org/glsa/201701-49
Get alerted when CVE-2016-9845 or the next vulnerability affects your stack