What’s Vulnerable › Vulnerabilities
CVE-2016-9897
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-119
Description
Memory corruption resulting in a potentially exploitable crash during WebGL functions using a vector constructor with a varying array within libGLES. This vulnerability affects Firefox < 50.1, Firefox ESR < 45.6, and Thunderbird < 45.6.
Affected products
- Debian Linux: 8.0
- Mozilla Firefox: before 50.1 — fixed in 50.1
- Mozilla Firefox ESR: before 45.6 — fixed in 45.6
- Mozilla Thunderbird: before 45.6.0 — fixed in 45.6.0
- RedHat Enterprise Linux Server: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Workstation: 5.0, 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 50.1; Mozilla Firefox ESR 45.6; Mozilla Thunderbird 45.6.0. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2016-2946.html
- http://www.securityfocus.com/bid/94885
- http://www.securitytracker.com/id/1037461
- https://bugzilla.mozilla.org/show_bug.cgi?id=1301381
- https://security.gentoo.org/glsa/201701-15
- https://www.debian.org/security/2017/dsa-3757
- https://www.mozilla.org/security/advisories/mfsa2016-94/
- https://www.mozilla.org/security/advisories/mfsa2016-95/
- https://www.mozilla.org/security/advisories/mfsa2016-96/
- http://rhn.redhat.com/errata/RHSA-2016-2946.html
- http://www.securityfocus.com/bid/94885
- http://www.securitytracker.com/id/1037461
Get alerted when CVE-2016-9897 or the next vulnerability affects your stack