What’s Vulnerable › Vulnerabilities
CVE-2016-9901
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-20
Description
HTML tags received from the Pocket server will be processed without sanitization and any JavaScript code executed will be run in the "about:pocket-saved" (unprivileged) page, giving it access to Pocket's messaging API through HTML injection. This vulnerability affects Firefox ESR < 45.6 and Firefox < 50.1.
Affected products
- Mozilla Firefox: before 45.6.0; before 50.1 — fixed in 45.6.0, 50.1
- RedHat Enterprise Linux Aus: 7.3, 7.4
- RedHat Enterprise Linux Desktop: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Eus: 7.3, 7.4, 7.5
- RedHat Enterprise Linux Server: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Workstation: 5.0, 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 45.6.0, 50.1. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2016-2946.html
- http://rhn.redhat.com/errata/RHSA-2016-2973.html
- http://www.securityfocus.com/bid/94885
- http://www.securitytracker.com/id/1037461
- https://bugzilla.mozilla.org/show_bug.cgi?id=1320057
- https://security.gentoo.org/glsa/201701-15
- https://www.mozilla.org/security/advisories/mfsa2016-94/
- https://www.mozilla.org/security/advisories/mfsa2016-95/
- http://rhn.redhat.com/errata/RHSA-2016-2946.html
- http://rhn.redhat.com/errata/RHSA-2016-2973.html
- http://www.securityfocus.com/bid/94885
- http://www.securitytracker.com/id/1037461
Get alerted when CVE-2016-9901 or the next vulnerability affects your stack