What’s Vulnerable › Vulnerabilities
CVE-2016-9919
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-12-08 · updated 2026-06-17
- Weakness: CWE-20
Description
The icmp6_send function in net/ipv6/icmp.c in the Linux kernel through 4.8.12 omits a certain check of the dst data structure, which allows remote attackers to cause a denial of service (panic) via a fragmented IPv6 packet.
Affected products
- Linux kernel: from 4.8.10 before 4.9; 4.4.223, 4.9-rc6, 4.9-rc7 — fixed in 4.9
How to fix
Upgrade to a fixed version: Linux kernel 4.9. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=79dc7e3f1cd323be4c81aa1a94faa1b3ed987fb2
- http://www.openwall.com/lists/oss-security/2016/12/08/15
- http://www.securityfocus.com/bid/94824
- https://github.com/torvalds/linux/commit/79dc7e3f1cd323be4c81aa1a94faa1b3ed987fb2
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=79dc7e3f1cd323be4c81aa1a94faa1b3ed987fb2
- http://www.openwall.com/lists/oss-security/2016/12/08/15
- http://www.securityfocus.com/bid/94824
- https://github.com/torvalds/linux/commit/79dc7e3f1cd323be4c81aa1a94faa1b3ed987fb2
Get alerted when CVE-2016-9919 or the next vulnerability affects your stack