What’s Vulnerable › Vulnerabilities
CVE-2016-9928
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-06 · updated 2026-06-17
- Weakness: CWE-269
Description
MCabber before 1.0.4 is vulnerable to roster push attacks, which allows remote attackers to intercept communications, or add themselves as an entity on a 3rd party's roster as another user, which will also garner associated privileges, via crafted XMPP packets.
Affected products
- Canonical Ubuntu Linux: 16.04
- Debian Linux: 8.0
- MCabber: from 1.0.0 before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: MCabber 1.0.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2017-01/msg00130.html
- http://www.openwall.com/lists/oss-security/2016/12/11/2
- http://www.openwall.com/lists/oss-security/2017/02/09/29
- http://www.securityfocus.com/bid/94862
- https://bitbucket.org/McKael/mcabber-crew/commits/6e1ead98930d7dd0a520ad17c720ae4908429033/raw
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=845258
- https://bugzilla.redhat.com/show_bug.cgi?id=1403790
- https://gultsch.de/gajim_roster_push_and_message_interception.html
- https://lists.debian.org/debian-lts-announce/2020/06/msg00031.html
- https://usn.ubuntu.com/4506-1/
- http://lists.opensuse.org/opensuse-updates/2017-01/msg00130.html
- http://www.openwall.com/lists/oss-security/2016/12/11/2
Get alerted when CVE-2016-9928 or the next vulnerability affects your stack