What’s Vulnerable › Vulnerabilities
CVE-2016-9955
- Severity: medium (CVSS 6.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-02-17 · updated 2026-06-17
- Weakness: CWE-20
Description
The SimpleSAML_XML_Validator class constructor in SimpleSAMLphp before 1.14.11 might allow remote attackers to spoof signatures on SAML 1 responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.
Affected products
- Debian Linux: 7.0
- simplesamlphp: before 1.14.11 — fixed in 1.14.11
How to fix
Upgrade to a fixed version: simplesamlphp 1.14.11. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94946
- https://lists.debian.org/debian-lts-announce/2018/03/msg00001.html
- https://simplesamlphp.org/security/201612-02
- http://www.securityfocus.com/bid/94946
- https://lists.debian.org/debian-lts-announce/2018/03/msg00001.html
- https://simplesamlphp.org/security/201612-02
Get alerted when CVE-2016-9955 or the next vulnerability affects your stack