What’s Vulnerable › Vulnerabilities
CVE-2017-0356: Authentication bypass via repeated parameters
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-04-13 · updated 2026-06-17
- Weakness: CWE-287
Description
A flaw, similar to to CVE-2016-9646, exists in ikiwiki before 3.20170111, in the passwordauth plugin's use of CGI::FormBuilder, allowing an attacker to bypass authentication via repeated parameters.
Affected products
- Debian Linux: 7.0, 8.0
- ikiwiki: before 3.20170111 — fixed in 3.20170111
How to fix
Upgrade to a fixed version: ikiwiki 3.20170111. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95420
- https://ikiwiki.info/security/#cve-2017-0356
- https://marc.info/?l=oss-security&m=148418234314276&w=2
- https://www.debian.org/security/2017/dsa-3760
- http://www.securityfocus.com/bid/95420
- https://ikiwiki.info/security/#cve-2017-0356
- https://marc.info/?l=oss-security&m=148418234314276&w=2
- https://www.debian.org/security/2017/dsa-3760
Get alerted when CVE-2017-0356 or the next vulnerability affects your stack