What’s Vulnerable › Vulnerabilities
CVE-2017-0357: iucode-tool: heap buffer overflow on -tr loader
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-13 · updated 2026-06-17
- Weakness: CWE-119
Description
A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.
Affected products
- Debian Linux: 9.0
- Iucode-Tool Project Iucode-Tool: from 1.4 before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: Iucode-Tool Project Iucode-Tool 2.1.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95432
- https://gitlab.com/iucode-tool/iucode-tool/issues/3
- https://security-tracker.debian.org/tracker/CVE-2017-0357
- http://www.securityfocus.com/bid/95432
- https://gitlab.com/iucode-tool/iucode-tool/issues/3
- https://security-tracker.debian.org/tracker/CVE-2017-0357
Get alerted when CVE-2017-0357 or the next vulnerability affects your stack