What’s Vulnerable › Vulnerabilities
CVE-2017-0361: api.log contains passwords in plaintext
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-13 · updated 2026-06-17
- Weakness: CWE-200
Description
Mediawiki before 1.28.1 / 1.27.2 / 1.23.16 contains an information disclosure flaw, where the api.log might contain passwords in plaintext.
Affected products
- Debian Linux: 7.0
- Wikimedia Foundation MediaWiki: from 1.23.0 through 1.23.16; from 1.27.0 before 1.27.2; from 1.28.0 before 1.28.1 — fixed in 1.27.2, 1.28.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.27.2, 1.28.1. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1039812
- https://lists.wikimedia.org/pipermail/mediawiki-announce/2017-April/000207.html
- https://phabricator.wikimedia.org/T125177
- https://security-tracker.debian.org/tracker/CVE-2017-0361
- http://www.securitytracker.com/id/1039812
- https://lists.wikimedia.org/pipermail/mediawiki-announce/2017-April/000207.html
- https://phabricator.wikimedia.org/T125177
- https://security-tracker.debian.org/tracker/CVE-2017-0361
Get alerted when CVE-2017-0361 or the next vulnerability affects your stack