What’s Vulnerable › Vulnerabilities
CVE-2017-0371
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-18 · updated 2026-06-17
Description
MediaWiki before 1.23.16, 1.24.x through 1.27.x before 1.27.2, and 1.28.x before 1.28.1 allows remote attackers to discover the IP addresses of Wiki visitors via a style="background-image: attr(title url);" attack within a DIV element that has an attacker-controlled URL in the title attribute.
Affected products
- Wikimedia Foundation MediaWiki: before 1.23.16; from 1.24.0 before 1.27.2; from 1.28.0 before 1.28.1 — fixed in 1.23.16, 1.27.2, 1.28.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.23.16, 1.27.2, 1.28.1. Check the vendor advisory for mitigations.
References
- https://phabricator.wikimedia.org/T140591
- https://phabricator.wikimedia.org/T68404
- https://phabricator.wikimedia.org/T140591
- https://phabricator.wikimedia.org/T68404
Get alerted when CVE-2017-0371 or the next vulnerability affects your stack