What’s Vulnerable › Vulnerabilities
CVE-2017-0887
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-05 · updated 2026-06-17
- Weakness: CWE-807
Description
Nextcloud Server before 9.0.55 and 10.0.2 suffers from a bypass in the quota limitation. Due to not properly sanitizing values provided by the `OC-Total-Length` HTTP header an authenticated adversary may be able to exceed their configured user quota. Thus using more space than allowed by the administrator.
Affected products
- Nextcloud Server: before 9.0.55; from 10.0.0 before 10.0.2 — fixed in 10.0.2, 9.0.55
How to fix
Upgrade to a fixed version: Nextcloud Server 10.0.2, 9.0.55. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/173622
- https://nextcloud.com/security/advisory/?id=nc-sa-2017-005
- https://hackerone.com/reports/173622
- https://nextcloud.com/security/advisory/?id=nc-sa-2017-005
Get alerted when CVE-2017-0887 or the next vulnerability affects your stack