What’s Vulnerable › Vulnerabilities
CVE-2017-0889
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-13 · updated 2026-06-17
- Weakness: CWE-918
Description
Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.
Affected products
- thoughtbot paperclip ruby gem: from 3.1.4 before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: thoughtbot paperclip ruby gem 5.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/thoughtbot/paperclip/pull/2435
- https://hackerone.com/reports/209430
- https://hackerone.com/reports/713
- https://github.com/thoughtbot/paperclip/pull/2435
- https://hackerone.com/reports/209430
- https://hackerone.com/reports/713
Get alerted when CVE-2017-0889 or the next vulnerability affects your stack