What’s Vulnerable › Vulnerabilities
CVE-2017-0890
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-05-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Nextcloud Server before 11.0.3 is vulnerable to an inadequate escaping leading to a XSS vulnerability in the search module. To be exploitable a user has to write or paste malicious content into the search dialogue.
Affected products
- Nextcloud Server: before 11.0.3 — fixed in 11.0.3
How to fix
Upgrade to a fixed version: Nextcloud Server 11.0.3. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/213227
- https://nextcloud.com/security/advisory/?id=nc-sa-2017-007
- https://hackerone.com/reports/213227
- https://nextcloud.com/security/advisory/?id=nc-sa-2017-007
Get alerted when CVE-2017-0890 or the next vulnerability affects your stack