What’s Vulnerable › Vulnerabilities

CVE-2017-0893

Description

Nextcloud Server before 9.0.58 and 10.0.5 and 11.0.3 are shipping a vulnerable JavaScript library for sanitizing untrusted user-input which suffered from a XSS vulnerability caused by a behaviour change in Safari 10.1 and 10.2. Note that Nextcloud employs a strict Content-Security-Policy preventing exploitation of this XSS issue on modern web browsers.

Affected products

How to fix

Upgrade to a fixed version: Nextcloud Server 10.0.5, 11.0.3, 9.0.58. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-0893 or the next vulnerability affects your stack