What’s Vulnerable › Vulnerabilities
CVE-2017-0929
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-03 · updated 2026-06-17
- Weakness: CWE-918
Description
DNN (aka DotNetNuke) before 9.2.0 suffers from a Server-Side Request Forgery (SSRF) vulnerability in the DnnImageHandler class. Attackers may be able to access information about internal network resources.
Affected products
- DotNetNuke CMS Fixed in 9.1.1: before 9.2.0 — fixed in 9.2.0
How to fix
Upgrade to a fixed version: DotNetNuke CMS Fixed in 9.1.1 9.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/dnnsoftware/Dnn.Platform/commit/d3953db85fee77bb5e6383747692c507ef8b94c3
- https://github.com/dnnsoftware/Dnn.Platform/commit/d3953db85fee77bb5e6383747692c507ef8b94c3
Get alerted when CVE-2017-0929 or the next vulnerability affects your stack