What’s Vulnerable › Vulnerabilities

CVE-2017-1000052

Description

Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to null byte injection in the Plug.Static component, which may allow users to bypass filetype restrictions.

Affected products

How to fix

Upgrade to a fixed version: Plug Project Plug 1.0.4, 1.1.7, 1.2.3, 1.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-1000052 or the next vulnerability affects your stack