What’s Vulnerable › Vulnerabilities
CVE-2017-1000115
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-10-05 · updated 2026-06-17
- Weakness: CWE-59
Description
Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository
Affected products
- Debian Linux: 8.0, 9.0
- mercurial: before 4.3 — fixed in 4.3
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.4, 7.6
- RedHat Enterprise Linux Server Eus: 7.4, 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.4, 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: mercurial 4.3. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3963
- http://www.securityfocus.com/bid/100290
- https://access.redhat.com/errata/RHSA-2017:2489
- https://security.gentoo.org/glsa/201709-18
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.3_.2F_4.3.1_.282017-08-10.29
- http://www.debian.org/security/2017/dsa-3963
- http://www.securityfocus.com/bid/100290
- https://access.redhat.com/errata/RHSA-2017:2489
- https://security.gentoo.org/glsa/201709-18
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.3_.2F_4.3.1_.282017-08-10.29
Get alerted when CVE-2017-1000115 or the next vulnerability affects your stack