What’s Vulnerable › Vulnerabilities
CVE-2017-1000121
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-01 · updated 2026-06-17
- Weakness: CWE-190
Description
The UNIX IPC layer in WebKit, including WebKitGTK+ prior to 2.16.3, does not properly validate message size metadata, allowing a compromised secondary process to trigger an integer overflow and subsequent buffer overflow in the UI process. This vulnerability does not affect Apple products.
Affected products
- Webkitgtk+: before 2.16.3 — fixed in 2.16.3
How to fix
Upgrade to a fixed version: Webkitgtk+ 2.16.3. Check the vendor advisory for mitigations.
References
- http://trac.webkit.org/changeset/217126/webkit
- https://webkitgtk.org/security/WSA-2017-0007.html
- http://trac.webkit.org/changeset/217126/webkit
Get alerted when CVE-2017-1000121 or the next vulnerability affects your stack