What’s Vulnerable › Vulnerabilities
CVE-2017-1000122
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-01 · updated 2026-06-17
- Weakness: CWE-20
Description
The UNIX IPC layer in WebKit, including WebKitGTK+ prior to 2.16.3, does not properly validate certain message metadata, allowing a compromised secondary process to cause a denial of service (release assertion) of the UI process. This vulnerability does not affect Apple products.
Affected products
- Webkitgtk+: before 2.16.3 — fixed in 2.16.3
How to fix
Upgrade to a fixed version: Webkitgtk+ 2.16.3. Check the vendor advisory for mitigations.
References
- http://trac.webkit.org/changeset/217206
- https://webkitgtk.org/security/WSA-2017-0007.html
- http://trac.webkit.org/changeset/217206
Get alerted when CVE-2017-1000122 or the next vulnerability affects your stack