What’s Vulnerable › Vulnerabilities
CVE-2017-1000158
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-17 · updated 2026-10-08
- Weakness: CWE-190
Description
CPython (aka Python) up to 2.7.13 is vulnerable to an integer overflow in the PyString_DecodeEscape function in stringobject.c, resulting in heap-based buffer overflow (and possible arbitrary code execution)
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- Python: before 2.7.15; from 3.4.0 before 3.4.8; from 3.5.0 before 3.5.5 — fixed in 2.7.15, 3.4.8, 3.5.5
How to fix
Upgrade to a fixed version: Python 2.7.15, 3.4.8, 3.5.5. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1039890
- https://bugs.python.org/issue30657
- https://lists.debian.org/debian-lts-announce/2017/11/msg00035.html
- https://lists.debian.org/debian-lts-announce/2017/11/msg00036.html
- https://lists.debian.org/debian-lts-announce/2018/09/msg00030.html
- https://lists.debian.org/debian-lts-announce/2018/09/msg00031.html
- https://security.gentoo.org/glsa/201805-02
- https://security.netapp.com/advisory/ntap-20230216-0001/
- https://www.debian.org/security/2018/dsa-4307
- http://www.securitytracker.com/id/1039890
- https://bugs.python.org/issue30657
- https://lists.debian.org/debian-lts-announce/2017/11/msg00035.html
Get alerted when CVE-2017-1000158 or the next vulnerability affects your stack