What’s Vulnerable › Vulnerabilities
CVE-2017-1000159
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-27 · updated 2026-06-17
- Weakness: CWE-78
Description
Command injection in evince via filename when printing to PDF. This affects versions earlier than 3.25.91.
Affected products
- GNOME Evince: before 3.25.91 — fixed in 3.25.91
How to fix
Upgrade to a fixed version: GNOME Evince 3.25.91. Check the vendor advisory for mitigations.
References
- https://bugzilla.gnome.org/show_bug.cgi?id=784947
- https://lists.debian.org/debian-lts-announce/2017/12/msg00006.html
- https://lists.debian.org/debian-lts-announce/2019/08/msg00013.html
- https://lists.debian.org/debian-lts-announce/2019/08/msg00014.html
- https://seclists.org/bugtraq/2020/Feb/18
- https://security.gentoo.org/glsa/201804-15
- https://www.debian.org/security/2020/dsa-4624
- https://bugzilla.gnome.org/show_bug.cgi?id=784947
- https://lists.debian.org/debian-lts-announce/2017/12/msg00006.html
- https://lists.debian.org/debian-lts-announce/2019/08/msg00013.html
- https://lists.debian.org/debian-lts-announce/2019/08/msg00014.html
- https://seclists.org/bugtraq/2020/Feb/18
Get alerted when CVE-2017-1000159 or the next vulnerability affects your stack