What’s Vulnerable › Vulnerabilities
CVE-2017-1000189
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-17 · updated 2026-06-17
- Weakness: CWE-20
Description
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
Affected products
- Ejs: before 2.5.5 — fixed in 2.5.5
How to fix
Upgrade to a fixed version: Ejs 2.5.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/101893
- https://github.com/mde/ejs/commit/49264e0037e313a0a3e033450b5c184112516d8f
- http://www.securityfocus.com/bid/101893
- https://github.com/mde/ejs/commit/49264e0037e313a0a3e033450b5c184112516d8f
Get alerted when CVE-2017-1000189 or the next vulnerability affects your stack