What’s Vulnerable › Vulnerabilities
CVE-2017-1000228
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-11-17 · updated 2026-06-17
- Weakness: CWE-20
Description
nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function
Affected products
- Ejs: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: Ejs 2.5.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/101897
- https://snyk.io/vuln/npm:ejs:20161128
- http://www.securityfocus.com/bid/101897
- https://snyk.io/vuln/npm:ejs:20161128
Get alerted when CVE-2017-1000228 or the next vulnerability affects your stack