What’s Vulnerable › Vulnerabilities
CVE-2017-1000246
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-17 · updated 2026-06-17
- Weakness: CWE-330
Description
Python package pysaml2 version 4.4.0 and earlier reuses the initialization vector across encryptions in the IDP server, resulting in weak encryption of data.
Affected products
- IdentityPython pysaml2: before 4.6.0 — fixed in 4.6.0
How to fix
Upgrade to a fixed version: IdentityPython pysaml2 4.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-1000246 or the next vulnerability affects your stack