What’s Vulnerable › Vulnerabilities
CVE-2017-1000253: Linux Kernel PIE Stack Buffer Corruption Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2024-09-09
- EPSS: 10.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-10-05 · updated 2026-06-17
- Weakness: CWE-119
Description
Linux distributions that have not patched their long-term kernels with https://git.kernel.org/linus/a87938b2e246b81b4fb713edb371a9fa3c5c3c86 (committed on April 14, 2015). This kernel vulnerability was fixed in April 2015 by commit a87938b2e246b81b4fb713edb371a9fa3c5c3c86 (backported to Linux 3.10.77 in May 2015), but it was not recognized as a security threat. With CONFIG_ARCH_BINFMT_ELF_RANDOMIZE_PIE enabled, and a normal top-down address allocation strategy, load_elf_binary() will attempt to map a PIE binary into an address range immediately below mm->mmap_base. Unfortunately, load_elf_ binary() does not take account of the need to allocate sufficient space for the entire binary which means that, while the first PT_LOAD segment is mapped below mm->mmap_base, the subsequent PT_LOAD segment(s) end up being mapped above mm->mmap_base into the are that is supposed to be the "gap" between the stack and the binary.
Affected products
- Centos: 6.0, 6.1, 6.2, 6.3, 6.4, 6.5 (+8)
- Linux kernel: from 2.6.25 before 3.2.70; from 3.3 before 3.4.109; from 3.5 before 3.10.77; from 3.11 before 3.12.43; from 3.13 before 3.14.41; from 3.15 before 3.16.35 — fixed in 3.10.77, 3.12.43, 3.14.41, 3.16.35, 3.18.14, 3.19.7
- Red Hat Enterprise Linux: 6.0, 6.1, 6.2, 6.3, 6.4, 6.5 (+8)
How to fix
Upgrade to a fixed version: Linux kernel 3.10.77, 3.12.43, 3.14.41, 3.16.35. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/101010
- http://www.securitytracker.com/id/1039434
- https://access.redhat.com/errata/RHSA-2017:2793
- https://access.redhat.com/errata/RHSA-2017:2794
- https://access.redhat.com/errata/RHSA-2017:2795
- https://access.redhat.com/errata/RHSA-2017:2796
- https://access.redhat.com/errata/RHSA-2017:2797
- https://access.redhat.com/errata/RHSA-2017:2798
- https://access.redhat.com/errata/RHSA-2017:2799
- https://access.redhat.com/errata/RHSA-2017:2800
- https://access.redhat.com/errata/RHSA-2017:2801
- https://access.redhat.com/errata/RHSA-2017:2802
Get alerted when CVE-2017-1000253 or the next vulnerability affects your stack