What’s Vulnerable › Vulnerabilities
CVE-2017-1000256
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-10-31 · updated 2026-06-17
- Weakness: CWE-295
Description
libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.
Affected products
- Debian Linux: 9.0
- libvirt: from 2.3.0 before 3.9.0 — fixed in 3.9.0
How to fix
Upgrade to a fixed version: libvirt 3.9.0. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-4003
- https://access.redhat.com/security/cve/CVE-2017-1000256
- https://www.mail-archive.com/debian-bugs-dist%40lists.debian.org/msg1556251.html
- https://www.redhat.com/archives/libvirt-announce/2017-October/msg00001.html
- http://www.debian.org/security/2017/dsa-4003
- https://access.redhat.com/security/cve/CVE-2017-1000256
- https://www.mail-archive.com/debian-bugs-dist%40lists.debian.org/msg1556251.html
- https://www.redhat.com/archives/libvirt-announce/2017-October/msg00001.html
Get alerted when CVE-2017-1000256 or the next vulnerability affects your stack