What’s Vulnerable › Vulnerabilities
CVE-2017-1000363
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-07-17 · updated 2026-06-17
- Weakness: CWE-787
Description
Linux drivers/char/lp.c Out-of-Bounds Write. Due to a missing bounds check, and the fact that parport_ptr integer is static, a 'secure boot' kernel command line adversary (can happen due to bootloader vulns, e.g. Google Nexus 6's CVE-2016-10277, where due to a vulnerability the adversary has partial control over the command line) can overflow the parport_nr array in the following code, by appending many (>LP_NO) 'lp=none' arguments to the command line.
Affected products
- Debian Linux: 8.0
- Linux kernel: from 2.6.12 before 3.2.91; from 3.3 before 3.10.106; from 3.11 before 3.16.46; from 3.17 before 3.18.55; from 3.19 before 4.1.41; from 4.2 before 4.4.70 — fixed in 3.10.106, 3.16.46, 3.18.55, 3.2.91, 4.1.41, 4.11.3
How to fix
Upgrade to a fixed version: Linux kernel 3.10.106, 3.16.46, 3.18.55, 3.2.91. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3945
- http://www.securityfocus.com/bid/98651
- https://alephsecurity.com/vulns/aleph-2017023
- http://www.debian.org/security/2017/dsa-3945
- http://www.securityfocus.com/bid/98651
- https://alephsecurity.com/vulns/aleph-2017023
Get alerted when CVE-2017-1000363 or the next vulnerability affects your stack