What’s Vulnerable › Vulnerabilities
CVE-2017-1000370
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-06-19 · updated 2026-06-17
Description
The offset2lib patch as used in the Linux Kernel contains a vulnerability that allows a PIE binary to be execve()'ed with 1GB of arguments or environmental strings then the stack occupies the address 0x80000000 and the PIE binary is mapped above 0x40000000 nullifying the protection of the offset2lib patch. This affects Linux Kernel version 4.11.5 and earlier. This is a different issue than CVE-2017-1000371. This issue appears to be limited to i386 based systems.
Affected products
- Linux kernel: from 4.1 before 4.1.43; from 4.2 before 4.4.78; from 4.5 before 4.9.39; from 4.10 before 4.11.12; from 4.12 before 4.12.3 — fixed in 4.1.43, 4.11.12, 4.12.3, 4.4.78, 4.9.39
How to fix
Upgrade to a fixed version: Linux kernel 4.1.43, 4.11.12, 4.12.3, 4.4.78. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3981
- http://www.securityfocus.com/bid/99149
- https://access.redhat.com/security/cve/CVE-2017-1000370
- https://www.exploit-db.com/exploits/42273/
- https://www.exploit-db.com/exploits/42274/
- https://www.qualys.com/2017/06/19/stack-clash/stack-clash.txt
- http://www.debian.org/security/2017/dsa-3981
- http://www.securityfocus.com/bid/99149
- https://access.redhat.com/security/cve/CVE-2017-1000370
- https://www.exploit-db.com/exploits/42273/
- https://www.exploit-db.com/exploits/42274/
- https://www.qualys.com/2017/06/19/stack-clash/stack-clash.txt
Get alerted when CVE-2017-1000370 or the next vulnerability affects your stack