What’s Vulnerable › Vulnerabilities

CVE-2017-1000376

Description

libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack. Please note that libffi is used by a number of other libraries. It was previously stated that this affects libffi version 3.2.1 but this appears to be incorrect. libffi prior to version 3.1 on 32 bit x86 systems was vulnerable, and upstream is believed to have fixed this issue in version 3.1.

Affected products

How to fix

Upgrade to a fixed version: Libffi Project Libffi 3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-1000376 or the next vulnerability affects your stack