What’s Vulnerable › Vulnerabilities
CVE-2017-1000427: Marked vulnerable to XSS from data URIs
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-02 · updated 2026-06-17
- Weakness: CWE-79
Description
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
Affected products
- markedjs marked: through 0.3.6
- Npm Marked: before 0.3.7 — fixed in 0.3.7
How to fix
Upgrade to a fixed version: Npm Marked 0.3.7. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BO2RMVVZVV6NFTU46B5RYRK7ZCXYARZS/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M6BJG6RGDH7ZWVVAUFBFI5L32RSMQN2S/
- https://snyk.io/vuln/npm:marked:20170112
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BO2RMVVZVV6NFTU46B5RYRK7ZCXYARZS/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M6BJG6RGDH7ZWVVAUFBFI5L32RSMQN2S/
- https://snyk.io/vuln/npm:marked:20170112
Get alerted when CVE-2017-1000427 or the next vulnerability affects your stack