What’s Vulnerable › Vulnerabilities
CVE-2017-1000445
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-02 · updated 2026-06-17
- Weakness: CWE-476
Description
ImageMagick 7.0.7-1 and older version are vulnerable to null pointer dereference in the MagickCore component and might lead to denial of service
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- ImageMagick: before 6.9.9-15; from 7.0.0-0 through 7.0.7-1 — fixed in 6.9.9-15
How to fix
Upgrade to a fixed version: ImageMagick 6.9.9-15. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102368
- https://github.com/ImageMagick/ImageMagick/issues/775
- https://lists.debian.org/debian-lts-announce/2018/01/msg00002.html
- https://lists.debian.org/debian-lts-announce/2019/05/msg00015.html
- https://lists.debian.org/debian-lts-announce/2020/09/msg00007.html
- https://usn.ubuntu.com/3681-1/
- http://www.securityfocus.com/bid/102368
- https://github.com/ImageMagick/ImageMagick/issues/775
- https://lists.debian.org/debian-lts-announce/2018/01/msg00002.html
- https://lists.debian.org/debian-lts-announce/2019/05/msg00015.html
- https://lists.debian.org/debian-lts-announce/2020/09/msg00007.html
- https://usn.ubuntu.com/3681-1/
Get alerted when CVE-2017-1000445 or the next vulnerability affects your stack