What’s Vulnerable › Vulnerabilities

CVE-2017-1000479

Description

pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under "possibly insecure" suspicions.

Affected products

How to fix

Upgrade to a fixed version: Opnsense Project Opnsense 16.1.16. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-1000479 or the next vulnerability affects your stack