What’s Vulnerable › Vulnerabilities
CVE-2017-1000480
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-03 · updated 2026-06-17
- Weakness: CWE-94
Description
Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.
Affected products
- Smarty: from 3.0.0 before 3.1.32 — fixed in 3.1.32
How to fix
Upgrade to a fixed version: Smarty 3.1.32. Check the vendor advisory for mitigations.
References
- https://github.com/smarty-php/smarty/blob/master/change_log.txt
- https://lists.debian.org/debian-lts-announce/2018/01/msg00023.html
- https://lists.debian.org/debian-lts-announce/2018/02/msg00000.html
- https://www.debian.org/security/2018/dsa-4094
- https://github.com/smarty-php/smarty/blob/master/change_log.txt
- https://lists.debian.org/debian-lts-announce/2018/01/msg00023.html
- https://lists.debian.org/debian-lts-announce/2018/02/msg00000.html
- https://www.debian.org/security/2018/dsa-4094
Get alerted when CVE-2017-1000480 or the next vulnerability affects your stack