What’s Vulnerable › Vulnerabilities
CVE-2017-1000487
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-03 · updated 2026-06-17
- Weakness: CWE-78
Description
Plexus-utils before 3.0.16 is vulnerable to command injection because it does not correctly process the contents of double quoted strings.
Affected products
- codehaus-plexus Plexus-Utils: before 3.0.16 — fixed in 3.0.16
- Debian Linux: 7.0, 8.0, 9.0
How to fix
Upgrade to a fixed version: codehaus-plexus Plexus-Utils 3.0.16. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:1322
- https://github.com/codehaus-plexus/plexus-utils/commit/b38a1b3a4352303e4312b2bb601a0d7ec6e28f41
- https://lists.apache.org/thread.html/9317fd092b257a0815434b116a8af8daea6e920b6673f4fd5583d5fe%40%3Ccommits.druid.apache.org%3E
- https://lists.apache.org/thread.html/r2e94f72f53df432302d359fd66cfa9e9efb8d42633d54579a4377e62%40%3Cdev.avro.apache.org%3E
- https://lists.apache.org/thread.html/r9584c4304c888f651d214341a939bd264ed30c9e3d0d30fe85097ecf%40%3Ccommits.pulsar.apache.org%3E
- https://lists.apache.org/thread.html/rd0e44e8ef71eeaaa3cf3d1b8b41eb25894372e2995ec908ce7624d26%40%3Ccommits.pulsar.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2018/01/msg00010.html
- https://lists.debian.org/debian-lts-announce/2018/01/msg00011.html
- https://snyk.io/vuln/SNYK-JAVA-ORGCODEHAUSPLEXUS-31522
- https://www.debian.org/security/2018/dsa-4146
- https://www.debian.org/security/2018/dsa-4149
- https://access.redhat.com/errata/RHSA-2018:1322
Get alerted when CVE-2017-1000487 or the next vulnerability affects your stack