What’s Vulnerable › Vulnerabilities
CVE-2017-1000600
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-06 · updated 2026-06-17
- Weakness: CWE-20
Description
WordPress version <4.9 contains a CWE-20 Input Validation vulnerability in thumbnail processing that can result in remote code execution. This attack appears to be exploitable via thumbnail upload by an authenticated user and may require additional plugins in order to be exploited however this has not been confirmed at this time. This issue appears to have been partially, but not completely fixed in WordPress 4.9
Affected products
- WordPress: before 4.9 — fixed in 4.9
How to fix
Upgrade to a fixed version: WordPress 4.9. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105305
- https://www.theregister.co.uk/2018/08/20/php_unserialisation_wordpress_vuln/
- https://youtu.be/GePBmsNJw6Y?t=1763
- http://www.securityfocus.com/bid/105305
- https://www.theregister.co.uk/2018/08/20/php_unserialisation_wordpress_vuln/
- https://youtu.be/GePBmsNJw6Y?t=1763
Get alerted when CVE-2017-1000600 or the next vulnerability affects your stack