What’s Vulnerable › Vulnerabilities

CVE-2017-1002102

Description

In Kubernetes versions 1.3.x, 1.4.x, 1.5.x, 1.6.x and prior to versions 1.7.14, 1.8.9 and 1.9.4 containers using a secret, configMap, projected or downwardAPI volume can trigger deletion of arbitrary files/directories from the nodes where they are running.

Affected products

How to fix

Upgrade to a fixed version: Kubernetes 1.7.14, 1.8.9, 1.9.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-1002102 or the next vulnerability affects your stack