What’s Vulnerable › Vulnerabilities

CVE-2017-10140

Description

Postfix before 2.11.10, 3.0.x before 3.0.10, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 might allow local users to gain privileges by leveraging undocumented functionality in Berkeley DB 2.x and later, related to reading settings from DB_CONFIG in the current directory.

Affected products

How to fix

Upgrade to a fixed version: Postfix 2.11.10, 3.0.10, 3.1.6, 3.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-10140 or the next vulnerability affects your stack