What’s Vulnerable › Vulnerabilities
CVE-2017-10384
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-10-19 · updated 2026-06-17
Description
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: DDL). Supported versions that are affected are 5.5.57 and earlier 5.6.37 and earlier 5.7.19 and earlier. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 6.5 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H).
Affected products
- Debian Linux: 8.0
- MariaDB: from 5.5.0 before 5.5.57; from 10.0.0 before 10.0.32; from 10.1.0 before 10.1.26; from 10.2.0 before 10.2.8 — fixed in 10.0.32, 10.1.26, 10.2.8, 5.5.57
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: from 7.3; from 9.5
- NetApp Oncommand Balance: all versions
- OnCommand Insight: all versions
- NetApp Oncommand Performance Manager: all versions
- NetApp OnCommand Unified Manager for 7-Mode (core package): through 7.1
- NetApp OnCommand Workflow Automation: all versions
- NetApp SnapCenter: all versions
- MySQL Server: from 5.5.0 through 5.5.57; from 5.6.0 through 5.6.37; from 5.7.0 through 5.7.19
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Eus: 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.6, 7.7
- RedHat Enterprise Linux Workstation: 7.0
- OpenStack: 12
How to fix
Upgrade to a fixed version: MariaDB 10.0.32, 10.1.26, 10.2.8, 5.5.57. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-4002
- http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
- http://www.securityfocus.com/bid/101406
- http://www.securitytracker.com/id/1039597
- https://access.redhat.com/errata/RHSA-2017:3265
- https://access.redhat.com/errata/RHSA-2017:3442
- https://access.redhat.com/errata/RHSA-2018:0279
- https://access.redhat.com/errata/RHSA-2018:0574
- https://access.redhat.com/errata/RHSA-2018:2439
- https://access.redhat.com/errata/RHSA-2018:2729
- https://security.netapp.com/advisory/ntap-20171019-0002/
- http://www.debian.org/security/2017/dsa-4002
Get alerted when CVE-2017-10384 or the next vulnerability affects your stack