What’s Vulnerable › Vulnerabilities
CVE-2017-10671
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-06-29 · updated 2026-06-17
- Weakness: CWE-787
Description
Heap-based Buffer Overflow in the de_dotdot function in libhttpd.c in sthttpd before 2.27.1 allows remote attackers to cause a denial of service (daemon crash) or possibly have unspecified other impact via a crafted filename.
Affected products
- Sthttpd Project Sthttpd: before 2.27.1 — fixed in 2.27.1
How to fix
Upgrade to a fixed version: Sthttpd Project Sthttpd 2.27.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/06/15/9
- https://github.com/blueness/sthttpd/commit/c0dc63a49d8605649f1d8e4a96c9b468b0bff660
- https://github.com/blueness/sthttpd/releases/tag/v2.27.1
- http://www.openwall.com/lists/oss-security/2017/06/15/9
- https://github.com/blueness/sthttpd/commit/c0dc63a49d8605649f1d8e4a96c9b468b0bff660
- https://github.com/blueness/sthttpd/releases/tag/v2.27.1
Get alerted when CVE-2017-10671 or the next vulnerability affects your stack