What’s Vulnerable › Vulnerabilities
CVE-2017-10689
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-09 · updated 2026-06-17
- Weakness: CWE-269
Description
In previous versions of Puppet Agent it was possible to install a module with world writable permissions. Puppet Agent 5.3.4 and 1.10.10 included a fix to this vulnerability.
Affected products
- Canonical Ubuntu Linux: 14.04
- Puppet Agent: before 5.3.4; from 1.10.0 before 1.10.10 — fixed in 1.10.10, 5.3.4
- Puppet Enterprise: before 2016.4.10; from 2017.1.0 before 2017.3.4 — fixed in 2016.4.10, 2017.3.4
- Red Hat Satellite 6: 6.4
How to fix
Upgrade to a fixed version: Puppet Agent 1.10.10, 5.3.4; Puppet Enterprise 2016.4.10, 2017.3.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:2927
- https://puppet.com/security/cve/CVE-2017-10689
- https://usn.ubuntu.com/3567-1/
- https://access.redhat.com/errata/RHSA-2018:2927
- https://puppet.com/security/cve/CVE-2017-10689
- https://usn.ubuntu.com/3567-1/
Get alerted when CVE-2017-10689 or the next vulnerability affects your stack