What’s Vulnerable › Vulnerabilities
CVE-2017-10904
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-16 · updated 2026-06-17
- Weakness: CWE-78
Description
Qt for Android prior to 5.9.0 allows remote attackers to execute arbitrary OS commands via unspecified vectors.
Affected products
- Qt: before 5.9.0 — fixed in 5.9.0
How to fix
Upgrade to a fixed version: Qt 5.9.0. Check the vendor advisory for mitigations.
References
- https://blog.qt.io/blog/2017/11/22/security-advisory-qt-android/
- https://jvn.jp/en/jp/JVN67389262/index.html
- https://blog.qt.io/blog/2017/11/22/security-advisory-qt-android/
- https://jvn.jp/en/jp/JVN67389262/index.html
Get alerted when CVE-2017-10904 or the next vulnerability affects your stack