What’s Vulnerable › Vulnerabilities
CVE-2017-10905
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-16 · updated 2026-06-17
Description
A vulnerability in applications created using Qt for Android prior to 5.9.3 allows attackers to alter environment variables via unspecified vectors.
Affected products
- Qt: before 5.9.3 — fixed in 5.9.3
How to fix
Upgrade to a fixed version: Qt 5.9.3. Check the vendor advisory for mitigations.
References
- https://blog.qt.io/blog/2017/11/22/security-advisory-qt-android/
- https://jvn.jp/en/jp/JVN27342829/index.html
- https://blog.qt.io/blog/2017/11/22/security-advisory-qt-android/
- https://jvn.jp/en/jp/JVN27342829/index.html
Get alerted when CVE-2017-10905 or the next vulnerability affects your stack